Documentation

Previous Topic

Next Topic

V10 Client/Server Compatiblity

c-treeACE includes a number of security updates that required substantial changes to the FAIRCOM.FCS user and group information files. In addition, the authentication exchange sequence has been extensively modified to enhance network security. As a result, c-tree clients prior to V10 will be unable to connect to c-treeACE V10 servers. Also, V10 clients will not connect to prior servers. The following errors are now returned in these instances.

LSEC_ERR

941

This c-tree Server requires a secure logon that your c-tree client library does not support. Update your c-tree client library.

LSES_ERR

942

This c-tree client uses a secure logon that your c-tree Server does not support. Update your c-tree Server.

LSEV_ERR

959

This c-tree client uses a different secure logon version than your c-treeACE Server. Update your c-tree client.

PWDC_ERR

961

This c-tree Server requires a secure password transmission method that your c-tree client library does not support. Update your c-tree client library.

PWDS_ERR

962

This c-tree client uses a secure password transmission method that your c-treeACE Server does not support. Update your c-tree Server.

c-tree Plus ODBC Compatibility

Note that these V10 client server compatibility changes will impact existing c-tree Plus ODBC drivers (standalone). Please contact FairCom if you distribute these drivers and migrate to V10. Other options may be more applicable.

TOCIndex